Archived

This topic is now archived and is closed to further replies.

Help setting up SDL?

This topic is 5016 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Wow, that compiler reminded me very much of MS VC++...coincidence?

Be sure you have the lib files in a folder that the compiler knows about. Same with the include files.

Share this post


Link to post
Share on other sites
But in, like dev-cpp i need to "add" some compiler commands, i dont know about microsoft visual cpp though, but i think this is the same compiler as dev-cpp use, but im not sure though
anyone know for sure?

Share this post


Link to post
Share on other sites
Have you tried something and that doesn't work?
Or don't you know how to approach it?

Generally you have to add
-lmingw32 -lSDLmain -lSDL
to the linker.

I tried copying a Dev-Cpp project but I can't get it to work.
It does work in Dev-Cpp though.
My guess is that Files are included from \MinGWStudio\MinGW\include\ that I don't want.
Not sure why that happens ...

And I think it is not a SDL problem. So maybe describe what problems you have!?

[edited by - Clueless on March 19, 2004 8:07:34 AM]

Share this post


Link to post
Share on other sites
quote:
Original post by Muppi
But in, like dev-cpp i need to "add" some compiler commands, i dont know about microsoft visual cpp though, but i think this is the same compiler as dev-cpp use, but im not sure though
anyone know for sure?


Yeah, it does use the same compiler (MingW) as DevC++.

Share this post


Link to post
Share on other sites