Archived

This topic is now archived and is closed to further replies.

Radeon 9800pro strangeness

This topic is 5011 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, i seem to be having a little trouble with a game my company''s working on. So far, the problem only seems to happen on Radeon 9800pro cards. Here''s a screenshot of it: http://www3.sympatico.ca/eric.vanbeurden/error-shot.jpg It looks like a grill with many round holes has been placed over the screen, but the game isn''t rendering them (nor does it even have a texture resembling that) The game uses OpenGL 1.2+. I''m thinking it''s related to the multisample extension. I added that code a while ago, but was never able to test it because i don''t seem to have a card that fully supports the extension. I don''t personally have access to a Radeon 9800 card, so i can''t really test this bug out directly. Has anyone else run into a problem like this before?? Any help would be greatly appreciated =) thanks eric EST Games

Share this post


Link to post
Share on other sites
I don''t know. I would guess that somehow the radeon is applying a shader or effect (I dunno what the proper term would be). Maybe you should contact ATI?



(Stolen from Programmer One)
UNIX is an operating system, OS/2 is half an operating system, Windows is a shell, and DOS is a boot partition virus

Share this post


Link to post
Share on other sites
I''ve never seen that before. I use ARB_multisample on my Radeon 9700 pro with no problems, and it''s in fairly common usage, so I''d be surprised if it''s that. Maybe it''s a smartshader effect that someone has enabled in their display settings by mistake.

Share this post


Link to post
Share on other sites
i could see if it works on my system, i have the same card.

ddonahoe@vt.edu

it seems like settings->display->Settings->Advanced->3D
click the custom button, then click the "Trueform shader FX" tab and disable it. that may be your problem

[edited by - Mulligan on March 25, 2004 5:57:34 PM]

Share this post


Link to post
Share on other sites
well, i''ve so far figured out (with the awesome help of some nice testers =) ) that it''s some kind of an incompatibility with ATI''s FSAA option (of the "Always On" variety). I don''t have an ATI card that can deal with FSAA, so i can''t really test =( ... Does anyone know what could be causing this incompatibility? Wild stabs-in-the-dark are welcome!

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Lol, that looks like one of the effects you can enable under the device''s properties on the windows drivers. I can''t imagine what error would generate small, perfect circles.

Share this post


Link to post
Share on other sites
Hey AP: I can''t find anything like that under the device / driver settings... where is it? I read somewhere ATI had put options for post process effects into the drivers. Where is it please?

Share this post


Link to post
Share on other sites
If you are using any offscreen surfaces antialiasing can cause some superfunky effects - but I''ve never seen anything like this before. Definitely send this screenshot to ATI and copy/paste some rendering code along with it - their devrel ROCKS.

Share this post


Link to post
Share on other sites
yeah, the resolution is set properly - at least according to all the MSDN docs, and all the random articles on the web i''ve read. It''s been tested on many different platforms, and the res changes work every time.

I think that screen shot''s actually been resized by whoever took it (it was forwarded to me by my publisher). That screen shot was probably 800x600 originally, which would make each circle in the 25x19 grid 32x32 pixels. I don''t know whether the number of circles is resolution dependant though. It''s not something the game rendering on the screen. It''s being put there in some post-processing, pre-display step supported by the drivers. It goes away when FSAA is disabled.

Share this post


Link to post
Share on other sites