Archived

This topic is now archived and is closed to further replies.

Texture (non) filtering

This topic is 5013 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, Let''s take an example: chess. To representant the board, I think it''s useless to define a big texture (except for a photorealistic result). A 2x2 one is enough. Thus, when using such a small texture, you have to disable the texture filtering, don''t you? That''s what I''m trying to do. And I don''t understand because I explicitly call SetTextureStageState, with D3DTSS_MAG/MIN/MIPFILTER set to D3DTEXF_POINT or D3DTEXF_NONE, and it doesn''t work. The texture IS filtered... :-( Is there anything else to do, or is this call ignored under certain conditions, or have you any idea? Regards, -- Zavie

Share this post


Link to post
Share on other sites
Some drivers have an override for the texture filter settings.
If that is the case, you cannot toggle the filters in your own application - the only thing left to do is to use a higher-resolution map.

If the problem is not about the drivers, then the steps you mentioned should switch the filtering off.

-Nik

Share this post


Link to post
Share on other sites
Thanks a lot!

I've switched an option in the card's D3D properies, and that's ok.


--
Zavie

[edited by - Zavie on March 26, 2004 9:31:18 AM]

Share this post


Link to post
Share on other sites