Archived

This topic is now archived and is closed to further replies.

OpenAL32.dll

This topic is 4963 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

When i compile my openal code it compiles fine but when it runs it says it is missing the export OpenAL32.dll. How would you fix this i am using VC++ Thanks in advance Ructions

Share this post


Link to post
Share on other sites
Do you have the OpenAL32.dll on your computer? It should be in the windows directoy, or in your executable directory.
All it is telling you is that it cannot find the dll anywhere it''s looking

Spree

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
a quick fix would be to make sure that the DLL you are missing is in the same directory as say... all your openGL DLL files, cus you know that the compiler has linked to that directory for those DLLs, it will likely find the DLL you are missing if its in that one too.

Share this post


Link to post
Share on other sites
I think the problem is i am using a old dll file it was last modified in 2000 so its a bit old but i can seem to find a newer version on the web. anyone have an address for it.

Thanks in advance
Ructions

Share this post


Link to post
Share on other sites
Did you take a look on the http://www.openal.org site? There you should find new versions.

http://3das.noeska.com - Create 3D Adventure games without programming.

Share this post


Link to post
Share on other sites
just copy it directly into your game''s program directory as a start. if it doesn''t work fine then, go to the openAL website (google) and re-download the dlls and whatnot. if you''re releasing your game, you''ll have to ship it with the dll bundled in the game''s program directory anyway, so it''s not a big deal to put it there now.

-me

Share this post


Link to post
Share on other sites
i have done all that but it still comes up after it compliles that it cant link to the export OPENAL32.dll allnit. in a message box saying it can execute program so i dont know what the problem is.

any help would be greaful
ructions

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
quote:
Original post by Ructions
When i compile my openal code it compiles fine but when it runs it says it is missing the export OpenAL32.dll.

How would you fix this i am using VC++

Thanks in advance
Ructions


Share this post


Link to post
Share on other sites