Archived

This topic is now archived and is closed to further replies.

BradDaBug

Slackware!

Recommended Posts

Well, I finally did it! I ditched Red Hat and installed Slackware! So far it seems great! Fast and stable! But there's some problems. I'll list them and update this post as I get them fixed, and I may add some more as I discover more quirks. Any help is appreciated. Here, in no particular order, is my TODO list. 4. I installed Flash and now want to uninstall it!! BADLY! 12. Mozilla doesn't work for regular users. It begins to start up then just exits before anything appears off screen. The console just has this: *** Registering -webcal handler. *** Registering text/calendar handler. *** Registering webcal protocol handler. As soon as it prints that Mozilla just exits. It works fine under root. Did a chmod -R 755 chrome/ and it worked! 13. poweroff doesn't power off, it just sits there with "power down" or whatever that last message is. I'd like to get it to go ahead and shut off. 15. I can't access the Windows partition as a regular user. Permission denied. I've fixed this problem many times before off other installs, but I can never remember what I did. Awesome! Thanks for the help! But now, one more: 16. Must be root to shutdown. I want to be able to shut down as a regular user. Game Development Wiki [edited by - BradDaBug on March 30, 2004 2:16:19 PM]

Share this post


Link to post
Share on other sites
I haven''t used Slackware, myself, but I''ll give you some of what I know.

quote:
Original post by BradDaBug
1. Wheel on the mouse doesn''t work.



In /etc/X11/XF86Config-4 make sure there is

Option "ZAxisMapping" "4 5"

in the "Input Device" section for your mouse.

quote:

6. Red Hat used Grub, and Slackware uses Lilo. It seems like Grub was installed to the MBR while Lilo was installed at the other place (I can''t remember where that is). When my computer boots it goes to a Grub prompt, and since Red Hat is no longer there I''m unable to do anything. I have to boot Linux via the Slackware startup disk.



What''s /etc/lilo.conf look like? You can probably just change the device and rerun lilo to fix that. I''d be surprised if it was more complicated than that.

Image loads when I''m offline since I''m too lazy to find a permanent host.The following statement is true. The previous statement is false.
Shameless promotion:
FreePop: The GPL Populous II clone.

Share this post


Link to post
Share on other sites
quote:
Original post by BradDaBug
3. The Gnome terminal doesn''t display the current path in the prompt like Red Hat did
Edit your $PS1 in .bashrc. I have no idea what you need to display the path, ,but man bash should tell you (if you can decipher it).
quote:
4. I installed Flash and now want to uninstall it!! BADLY!
If you''re using Firefox, install the Flash Click-to-View extension. Otherwise, I dunno.

Share this post


Link to post
Share on other sites
quote:
Original post by BradDaBug
3. The Gnome terminal doesn''t display the current path in the prompt like Red Hat did



Have a look in ~/.bashrc Some where you may find the line PS1="...somestuff..." This is where you can configure the prompt. The switch you want in there is "\w" I believe.

Share this post


Link to post
Share on other sites
My lilo.conf file (minus a lot of comments):

# LILO configuration file
# generated by ''liloconfig''
#
# Start LILO global section
boot = /dev/hda5
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# End LILO global section
# DOS bootable partition config begins
other = /dev/hda1
label = DOS
table = /dev/hda
# DOS bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda5
label = Linux
read-only
# Linux bootable partition config ends


The /dev/hda5 is my linux partition and Windows is on /dev/hda1.

Share this post


Link to post
Share on other sites
Ok, I created (it didn''t exist) .bashrc and added the line:

PS1="\w/$ "

and that seems to work okay, but when the terminal is first started it just displays a ~ as the path instead of the full path. Anyone know how to get that much working?

Share this post


Link to post
Share on other sites
I''m probably not being constructive here, but if you ever get fed up with slackware because its package management is virtually nonexistant... debian is basically slackware with a real package manager. and a lot of packages. and a lot of other things. okay its a lot more than that, but I found the transition positively delightful.

Share this post


Link to post
Share on other sites
quote:
Original post by BradDaBug

boot = /dev/hda5




Change that to boot = /dev/hda, then rerun lilo.

Share this post


Link to post
Share on other sites
That did it!

Now I''ve just got to figure out what''s wrong with Gnome. I didn''t notice it start doing that (#10) until I started playing with the mouse section of the XF86Config file, but I doubt that has anything to do with it. Googling for "smb module init called" gives 0 results. I must have done something amazing to get it to do that.

Share this post


Link to post
Share on other sites
2. Uh, right.

3. The PS1 thing is the correct beginning. I don''t see why you don''t like it showing ~ for your home directory. Since you do, however, use $PWD instead of \w.

4. Okay, what files did it install? Removing them should be enough. A package manager makes this easier (). Removing the flash related symlink from /usr/lib/mozilla/plugins should be enough.

9. I can''t really remember how Slackware''s init scripts work. Look around in /etc for some init* or rc directory. If there''s more than one directory, they likely correspond to run levels. Place a script or symlink (as applicable) in the correct directory to whatever you''d like to run. There''s probably a helper script that automates this. This sounds like more bad packaging as it likely should have been done automatically.

10. If you haven''t touched anything, it sounds like something wrong with Slackware''s GNOME packaging. Likely fixable, but you should look up Dropline GNOME anyway (unofficial Slackware GNOME packages). What does ~/.xsession-errors have in it after you have a failed GNOME session?

11. Probably because of whatever is causing #10, like you seem to have discovered; fix that and you''ll have fixed this. You probably already know about Alt+Ctrl+F? to get to other virtual terminals.

12. If you haven''t touched anything, sounds like more poorly done packaging. Either way, make sure the Mozilla plug-ins and such are accessable by normal users.

What''s come of Slackware since I last used it ? (Probably not the common case, I do realize.) Sorry to pseudo-advertise, but I agree with C-Junkie; I switched from Slackware to Debian a while back and I''m very happy with it. If you''re just experimenting with distros and haven''t tried Debian, you may want to try it or one of its many derivatives sometime in the future.

Share this post


Link to post
Share on other sites
quote:
Original post by BradDaBug

3. The Gnome terminal doesn''t display the current path in the prompt like Red Hat did
4. I installed Flash and now want to uninstall it!! BADLY!
9. DHCP daemon isn''t running at startup, so I have to manually run it so that my machine gets an IP address for the network.
10. When Gnome starts up, the menu bar appears and disappears many times, then finally doesn''t come back. In the console there''s lots of messages over and over that say this:



3 :
Put this in ~/.bashrc and you get a nice prompt like this [user@host][working directory]$

export PS1=''[\u@\h][\w]$''

More info here

9 : run netconfig and select DHCP

Share this post


Link to post
Share on other sites
quote:
Original post by BradDaBug
13. poweroff doesn''t power off, it just sits there with "power down" or whatever that last message is. I''d like to get it to go ahead and shut off.


I believe you need to compile in (or have a loaded module of) APM or ACPI in the kernel. You might need to do a recompile if you compiled it yourself, or have your system load the apm or acpi module. One or the other.
quote:

15. I can''t access the Windows partition as a regular user. Permission denied. I''ve fixed this problem many times before off other installs, but I can never remember what I did.


I think you can hack /etc/fstab for this. "man fstab"

Image loads when I''m offline.The following statement is true. The previous statement is false.
Shameless promotion:
FreePop: The GPL Populous II clone.

Share this post


Link to post
Share on other sites
13. I had this problem once. The first answer I got here worked.

15. I also had this problem. Change your line in /etc/fstab to something like this (you may need to change it slightly for your drive):

/dev/hda1 /mnt/c ntfs ro,auto,users,umask=0000 1

I''m afraid I''ve never experienced your other problems still left.

Zorx (a Puzzle Bobble clone)
Discontinuity (an animation system for POV-Ray)

Share this post


Link to post
Share on other sites
If I recall correctly, shutting down as a regular user is not a problem with Slack provided that you''re running in the runlevel that starts an XDM (usually KDM or GDM) by default. In that case, you just go to shutdown/reboot either in _DM or in KDE/GNOME/whatever. If this doesn''t work, I''d suggest setting up sudo if you don''t really want to edit very many config files. That way ANYTHING you need to run as root, you can just type ''sudo do_whatever'' and you don''t have to login as root ever again (or type the root password using su).

Share this post


Link to post
Share on other sites
Advice like that is asking for a security breach. Be very careful about what programs you set the sticky bit on.

[edited by - Doc on March 31, 2004 12:42:50 AM]

Share this post


Link to post
Share on other sites

Debian = Slack + Real Package Manager + a large repository

Arch = Debian + extremely up to date packages + pacman which is better than apt-get + i686 optimization which makes it..FAST + allowing a simple base install which makes things easier to handle + being better

Share this post


Link to post
Share on other sites