Archived

This topic is now archived and is closed to further replies.

MeshMan

Z Buffer Problems

Recommended Posts

Hi all. Im currently making an asteroids game, due for completion midnight tonight (ciding competition with friends). If you take a look at this pic: http://meshman.no-ip.com/pic.jpg You will notice that the asteroids seem to be a little buggy, looks like its missing some triangles, but what gets me is that this only happens with people running GeFoce Ti cards. Ive tried it on about 10 machines (ATI / GeForce) and it only messes up on the GeForce4 Ti. I suspect its a Z Buffer problem but right before i draw my asteroids using glDrawElements() i do: glDepthMask(1); glDepthFunc(GL_LEQUAL); glClear(GL_DEPTH_BUFFER_BIT); glEnable(GL_DEPTH_TEST); glDrawElements...... But its still messed up. Can anyone help? Thanks. MeshMan

Share this post


Link to post
Share on other sites
Well, the calls to glDepthMask, glDepthFunc and glEnable should only occur once, in your OpenGL window initialization code (unless you turn off or change the depth buffer before you draw your asteroids). Other than that, it looks OK. Could the problem stem from anything else? Are you using the latest drivers on the GeForce 4 Ti? It could be that your problem was solved by a driver release...


Windows 95 - 32 bit extensions and a graphical shell for a 16 bit patch
to an 8 bit operating system originally coded for a 4 bit microprocessor,
written by a 2 bit company that can't stand 1 bit of competition.


[edited by - iNsAn1tY on April 5, 2004 6:35:19 AM]

Share this post


Link to post
Share on other sites
The machines that ran this demo and experienced this bug had installed the latest NVidia drivers. I cant think of anything else it could be other than the Z buffer. Any ideas?

Share this post


Link to post
Share on other sites