Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Nostalgia

GetDeviceIdentifier takes forever?

This topic is 5220 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey, all. I''m using DX8.1. I''ve got a LPDIRECTDRAW7 interface named lpdd. When I execute the following code on my windows 2000 system, it works perfectly. When I run it on my XP machine, the call to GetDeviceIdentifier() takes about 20 seconds to return. It does return successfully, and properly fill in the structure. I''ve commented out the code, since it''s just for logging purposes, but I''m fishing for ideas on why this could happen. Here''s the code: DDDEVICEIDENTIFIER2 id; ZeroMemory(&id, sizeof (DDDEVICEIDENTIFIER2)); hr = lpdd->GetDeviceIdentifier(&id, 0); if (FAILED(hr)) { DDErrorf(hr, "GetDeviceIdentifier Failed (LogDeviceStats):"); } else { Errorf("Video Driver Name: %s", id.szDriver); Errorf("Video Driver Description: %s", id.szDescription); } -Joe

Share this post


Link to post
Share on other sites
Advertisement

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!