• Advertisement

Archived

This topic is now archived and is closed to further replies.

KDevelop project

This topic is 5066 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

HELP!!! I want to set up a KDevelop project ... but I'm new to Linux. Everything works more or less. But when I try to run make it complains that g++ can't find -laa. What kind of library is that? Why do I need it? Am I doing something wrong? Does anybody else work with KDevelop and SDL? I tried to start a new project first ... but I want to run a game that I wrote in Dev-C++ under Linux. I know the code sucks ... but it is my first game and I'll rewrite it completely as soon as I get it to work under Linux ... Sourceforge file download [edited by - Clueless on April 13, 2004 10:11:34 AM]

Share this post


Link to post
Share on other sites
Advertisement
It's possible you didn't pass correct arguments to the linker, instead of a source code error, did you use a built in project type (a template) instead of a blank project? You may have unkowingly linked something you don't have, in fact check your linker options. there may be a line that says: "-lgnu32 -lSDLmain -lSDL -laa ". you know what to do



[edited by - Drakkcon on April 13, 2004 10:28:50 AM]

[edited by - Drakkcon on April 13, 2004 10:29:26 AM]

Share this post


Link to post
Share on other sites
I used a built in project type. Console c++ program afaik.
Because I saw a tutorial that suggested starting a console project or a custom project.
And custom project didn't work when I tried it ... I guess I should try that again?

The problem is that no configure and makefile stuff is created.

[edited by - Clueless on April 13, 2004 11:00:16 AM]

Share this post


Link to post
Share on other sites
Try a custom project type and link everything manually. You can refer to a tutorial on libsdl.org to show you how to set up the linker options. Everyone who uses SDL seems to have linker problems at first.

Share this post


Link to post
Share on other sites
It is not just a linker problem.
Because I''m new to makefiles and/or .configure files I can''t even add any linker parameters.
It is as if I didn''t create a new project.

---
Tolop

Share this post


Link to post
Share on other sites
So wait, you type make config and it makes, then when you use the includes they don''t work because you''re missing some library? All I can tell you is to search for the missing library online :/ Hope it works out....

Share this post


Link to post
Share on other sites
No ... it is like that:
if I start a custom project then I can''t use make.
Because there is no configure file.
If I start a console application project all those things are created automatically.
But when I add the sdl stuff to the linker and change int main() for SDL then the -laa not found problem occurs.

Now I guess I have to find out how people start custom projects successfully.
( How embarrassing is that ....cough )

Share this post


Link to post
Share on other sites
It could be that your SDL library is built with the ability to use the libaa ASCII Art library for rendering. Run sdl-config --libs and sdl-config --static-libs, and check the output to see if -laa is given as an included library link option. Also, you can go into your /usr/lib directory (or wherever your SDL libraries are located) and execute ldd libSDL-1.2.so.0 (your SDL shared library may be named differently; ls for it) to find out what dependencies the library requires. If -laa is an option output by sdl-config, or libaa is a required shared library listed by ldd, then you''ll either have to rebuild SDL (just grab the source and rebuild; configure should detect the absence of aa and exclude it), or build and install the ASCII Art library. Google turned up a page where source packages can be found here (at least, I believe it''s the one SDL uses).



Golem
Blender--The Gimp--Python--Lua--SDL
Nethack--Crawl--ADOM--Angband--Dungeondweller

Share this post


Link to post
Share on other sites

  • Advertisement