Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Cypher19

DX9SDK MultiAnimation example lighting problem

This topic is 5327 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I've implemented the MultiAnimation code into my program, but something I've noticed in my program is that Tiny cannot be lit by lights that I define, only by a single directional light defined in the MultiAnimat.fx HLSL shader. I know for sure that lighting in my program does work, since when using a plain static mesh it is properly lit. Does anyone know why Tiny is not being lit by my own lights, and is there some way to make it lit? (Note: I have even made the lights at the exact location of Tiny, and given the maximum range possible, but Tiny is still completely unlit) [edited by - Cypher19 on April 14, 2004 10:00:37 PM]

Share this post


Link to post
Share on other sites
Advertisement
You are rendering tiny with the shader. Not your normal dx so it isn''t gonna use dx''s lights. Look at Microsoft''s tutorial on doing shaders and lights. Also the .fx files are such a waste. I wouldn''t use those.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!