• Advertisement

Archived

This topic is now archived and is closed to further replies.

Cg Compile Errors with Visual Studio 2k3

This topic is 5122 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Advertisement
I''m getting unresolved external errors for every cg function call, the first thing I did was make sure I was including the cg.lib and cggl.lib. Sure enough they were. I''m baffled, could it be a Visual Studio 2k3 compatibility error?

Share this post


Link to post
Share on other sites
Hmm I doubt they wouldn''t work with VS.Net 2003. You sure the linker is actually finding the libary files? Are you sure you didn''t specify the libaries for the debug build and then do a release build or the other way round?

Share this post


Link to post
Share on other sites
Erm... I do assume that by ''Cg Program'' you do mean ''regular Windows application which uses Cg,'' rather than ''Cg Vertex/Fragment program?''

Share this post


Link to post
Share on other sites
Superpig - Yeah it''s an SDL/OpenAL/OpenGL program using Cg.

Monder - I tried the #pragma comment(lib,"cg.lib") method that I use for all my other libraries (sdl, opengl and openal) and it didn''t work either. If I rename cg.lib to cg.lib_ for example it comes back and says it can''t find cg.lib so I''m certain its finding cg.lib and cgGL.lib but there must be something causing it to screw up.

Share this post


Link to post
Share on other sites

  • Advertisement