Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

PartyOmNi

Visual C++.net noob question

This topic is 5149 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I just switched to Visual C++.net from 6.0. I can''t find the "compile" button. Where is it? I also had another problem with the language. I have a Japanese IME (multilanguage support bar) added on to my computer. The problem is, even with VC++6.0, or VC++.net, my "forward slashes" for newline and stuff becomes \(japanese yen sign). How can I get this fixed? Thank you for taking time to look at this noob question.

Share this post


Link to post
Share on other sites
Advertisement
By default you should have a build toolbar enabled. If not, right click on an empty space beside a toolbar, and check "Build". There you should have the build and rebuild commands. You can also rearrange the toolbars to your liking or even create own ones.

For the japanese stuff; no idea, you could try to change the editor font though.

Share this post


Link to post
Share on other sites
You could try replacing \''s with ??/ though I''m not sure how good MSVC6''s trigraph support is.

Share this post


Link to post
Share on other sites
thank you very much guys. Im just gonna contact microsoft about the Japanese. I just hate them, because even when registered a 1000 dollar program, their support is crap.

Thank you

Share this post


Link to post
Share on other sites
you should be able to compile with any “ú–{Œê characters... including the B

I have been using C# and the .NET framework to work on an app with Japanese characters and it seems to work fine, the only thing was saving my .cs file, or in your case .cpp into unicode format.

As for your backslash generating a  symbol, I don''t know about that... What exactly does this toolbar do for you? Windows has a cool Japanese IME that lets you switch from romaji, ‚Ђ炪‚ȁ@‚Ɓ@ƒJƒ^ƒJƒi@really easily, so you can probably get rid of that toolbar.

Good luck!

Share this post


Link to post
Share on other sites
Thank you...
every single time I start up windows, it starts up and the setting for the IME bar becomes japanese. I set it that way. However, when I program some thing like ...

#include <iostream>
using namespace std;

int main()
{
cout<<"hello world"\n"<
return 0;
}

my slashes are still the yen sign. Can I still compile like that?
Also, In the build button... can't you just compile with out adding it to a project? (Win 32 console)

Thank you for taking time to read this.

[edited by - partyomni on April 20, 2004 1:49:11 AM]

Share this post


Link to post
Share on other sites
quote:
Original post by PartyOmNi
#include <iostream>
using namespace std;

int main()
{
cout<<"hello world"\n"<
return 0;
}

my slashes are still the yen sign. Can I still compile like that?
If it''s the same (ASCII) code, then you can still compile it. AFAIK, some fonts (Unicode fonts primarily) render backslashes as Japanese Yen. They are still backslashes though. Why don''t you try?

Share this post


Link to post
Share on other sites
thank you for reply.. I do, but then it gives me an error message saying that...

Unable to start Debugging.

Unable to start program ''c\DocumentsandSettings...''

The system cannot find files specified.

which is weird because when I was running VC++6.0 with out the Japanese IME tool bar it would run.

my only options are to take out the Japanese or reinstall all my visual studio products.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!