Jump to content
  • Advertisement


This topic is now archived and is closed to further replies.


strange link error

This topic is 5199 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

--------------------Configuration: engine - Win32 Debug-------------------- Linking... LINK : fatal error LNK1102: out of memory Error executing link.exe. slickworm.exe - 1 error(s), 0 warning(s) I''d never saw this before.... my machine is p4 2.4c,512ddr

Share this post

Link to post
Share on other sites
Have you tried restarting visual studio? If that doesn''t help restart the computer. And if that still doesn''t help, check if you have enough free space on the drive your swapfile is and check the swapfile settings.

If the above doesn''t help, then I don''t know what''s the problem..

Share this post

Link to post
Share on other sites
From the online LINK documentation (suprisingly):


Linker Tools Error LNK1102
out of memory

There was not enough memory for the tool to run. Probably the paging file exceeded available disk space.

If a shortage of disk space is not the cause, note the circumstances of the error, try to isolate the problem and create a reproducible test case, then consult the technical-support help file or the technical-support section in one of your manuals.

[edited by - Nurgle on April 20, 2004 2:44:24 PM]

Share this post

Link to post
Share on other sites
This is a shot in the dark, but it could work...

A few tools attempt to read the amount of disc space, and convert it into a 32-bit signed integer in bytes.

This often results in an overflow and they think they''ve got a negative amount of space free.

So if you had 3Gb of space free on your C: drive (or wherever the linker puts its temp files), it might think it had -1G

As a total experiment, try having an amount of disc space free which results in a positive number of bytes 2''s complement 32bit.

For example: less than 2Gb, 4Gb-6Gb etc

I have actually seen this bug in other tools (MS SQL server 7 used to have this bug in some tools, if memory serves)


Share this post

Link to post
Share on other sites

  • Advertisement

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!