Archived

This topic is now archived and is closed to further replies.

de_matt

Turning off TCI_PASSTHRU

Recommended Posts

For my first pass I use a texture matrix to scale, translate the texture. After that I want to do some more passes using the texture coords stored in my vertices. I''ve tried this line : pd3ddevice->SetTextureStageState(1, D3DTEXTURETRANSFORMFLATS, D3DTIFF_DISABLE); That may not be exactly right but I use the D3DTIFF_DISABLE parameter in the right line and it doesn''t disable the use of the texture matrix. How can I disable the texture matrix after I''ve used it? Thanks de_matt

Share this post


Link to post
Share on other sites
No one can help?

Well, the only solution I can come up with is I use a tex matrix every time I use texture stage 1. I''d rather not but it''d be easily feasible. What does anyone think of doing this?

All I want to do is disable texture matrix transformations so that after I''ve used the tex matrix for one pass, I can use tex coords in the vertex structure for texture tiling.

Thanx

Matt

Share this post


Link to post
Share on other sites
Hi, to use the tex coord from your vertex buffer try adding the the following line:

pD3D->SetTextureStageState(1, D3DTSS_TEXCOORDINDEX, D3DTSS_TCI_PASSTHRU|1);

It should disable the use of the texture matrix.

Regards,
Oscar

Share this post


Link to post
Share on other sites