Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Hybrid666

another worldcraft problem :( (texture planes)

This topic is 5199 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hi, iv got code to calculate tex coords and code to make polys from brushes.. but wen i calculate texture coordinates for the polys im finding one of my arrays is in the wrong order, so texturing ends up messed up - iv tested it for hours and its definitly the arrays being in the wrong order.. i do things like this: load lines of a .MAP file, adding the plane definitons and texture stuff into an array, where each entry holds data for a line in the map file once a whole brush is loaded, i create polygons, exactly like the guides i have seen (especially the stefana one) then i calcualte the texture coords, but they wont work my array 1-6 of faces should match up to my array 1-6 of polygons (for a simple cube) but it doesnt and i cant think of a solution.. tried searching the brush for a plane definition that matched the plane definiton of my polygon, but that produced the same results.. im very confused :\ thanks in advance Hybrid

Share this post


Link to post
Share on other sites
Advertisement
This is really the wrong forum for file format issues. I''m moving to the game programming forum, which may be a better place.

Graham Rhodes
Principal Scientist
Applied Research Associates, Inc.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!