Archived

This topic is now archived and is closed to further replies.

soft shadow z-fighting

This topic is 4987 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am trying to implement soft shadows and in order to not have the overlapping shadows interfere and render patchy I have to use glPixelOffset each time I draw a new shadow and with larger values for the offset. I have read that if depth testing is disabled then you don''t need to do this. However if I disable depth testing my shadows either render elevated off the floor or render in patchy waves. Does anyone have any ideas?

Share this post


Link to post
Share on other sites