Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

3T

Multitexturing with more than 2 textures

This topic is 5237 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi How can I render more than 2 textures using multitexturing in one pass? I have a GeForce 4.

Share this post


Link to post
Share on other sites
Advertisement
Just activate GL_TEXTUREn, where n is 2 or more, and bind texture, set texture combiners and whatever you need to get the effect you''re after. There''s nothing different that using 2 textures.

Share this post


Link to post
Share on other sites
Cool Thanks! I thought it would have been really complicated

Share this post


Link to post
Share on other sites
It''s not working. The 3rd texture replaces the 2nd one.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
You better hope your "Geforce 4" doesn''t mean Geforce 4 MX xxx

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
The GeForce 4 mx series of cards only have two texture units.
The GeForce Fx series have 4 texture units.

Share this post


Link to post
Share on other sites
Thanks. My card is a Geforce 4 MX 440 How do I use multiple passes to do it instead?


[edited by - 3T on May 22, 2004 10:48:52 AM]

Share this post


Link to post
Share on other sites
hi, this is me again. I have a question about this too!! I''ve taking a look at the library lid3ds for loading a .3ds file (I made the file using 3ds max). when reading the file you get information about the lights, cameras, meshes and materials that are applied to the 3ds file. From what I understood, the material information was supposed to be the related information to the textures applied to each face of the 3d object, so when rendering the object, each material-texture will be located in its correct place....but it is not working. the example code does not enable texures, not even reading the bmp files (or at least I haven''t seen it), it just enabling the read material attached to each face when drawing the object....so I just can see plane colors....
I''ve read about this topic whitin this forum, but didn''t find any solution. Does anybody finally got it to work? Should I do something else before exporting the max scene to a .3ds file? please...need help again thanks

Share this post


Link to post
Share on other sites
quote:
Original post by 3T
Thanks. My card is a Geforce 4 MX 440 How do I use multiple passes to do it instead?


[edited by - 3T on May 22, 2004 10:48:52 AM]


Just render the geometry twice, the first time with the first 2 textures, the second time with the remaining texture(s). Render the first pass as you would normally do, so without blending, then the second pass with some sort of blending. You enable blending with glEnable(GL_BLEND), and you can set the blend mode with glBlendFunc. Note that you can''t do multiplication with this, only addition and alpha blending.

My Site

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!