Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

uber_n00b

Polygons aren't being filled mid-range

This topic is 5284 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

The title says it all. In my program I have a rather large draw distance (8192 units), and triangles in the midrange aren''t being filled all the way. It looks like there''s a big rip in the terrain that gradually disappears as you get closer. Could it have to do with depth testing not working at that range because the Z increment is too large? (I hope I used the right terminology). If so, how do I change this?

Share this post


Link to post
Share on other sites
Advertisement
What are you gluPerspective settings? With such a far far plane i''d suggest you use at least a 1.0 far near plane (maybe you''ll need even more). Could you post a screenshot or something?

Share this post


Link to post
Share on other sites
I took your advice and moved the draw distance forward to 6144 and it seems to work ok, so problem solved ^_^. Hah yeah I had the near-plane distance at 0.1F because my skybox is only 0.5F from each side of the camera (don''t ask).

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!