Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Tera_Dragon

stange flashes

This topic is 5277 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I''m getting some very strange things happening to my program. I have a button and when I put the mouse over it, it changes color. This worked fine and then I updated some other part of my program, ran it and the button flashed between it''s two textures. I hadn''t done anything to the ogl part of the code and so was stumped. I left it about a day, updated soem other stuff and when I ran it this time it worked. I thought that I must have changed something without realising it. When I finished workin on it for then it was working perfectly, but when I came back to it later the flashing between textures had started again. As I hadn''t even done anything to the code I want to know what is wrong. Could it be that my computer is running slower (more programs) and so you can see the screen refreshing? Please help this has been driving me crazy. Tera_Dragon ____________________________________________________________ Programmers Resource Central

Share this post


Link to post
Share on other sites
Advertisement
flashes what?

white? a different texture? flashes to the correct etxture that its supposed to when you mouseover, then falsehs back the the nonover one but the mouse is still over?

Share this post


Link to post
Share on other sites
quote:
Original post by C-Junkie
flashes to the correct etxture that its supposed to when you mouseover, then falsehs back the the nonover one but the mouse is still over?


exactly that. First of all it is green, then when the mouse is over it the texture changes to a red one. But it flashes VERY fast between the two. It wasn''t doing this before even though I havn''t changed the code at all.
Tera_Dragon

____________________________________________________________
Programmers Resource Central

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
make sure the right texture has been bound

Share this post


Link to post
Share on other sites
or if some other part of your code prosesses mouse input, make sure it doesn''t "steal" it away from the button.

or, you set the hover state on WM_MOUSEMOVE and resets it in some other update function without checking the mouse position.

endless possibilities... isn''t it fun?
=)

Hellsp4wn
-----------

I''m having deja-vu and amnesia at the same time. It''s like I think I''ve forgotten this before.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!