Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Raloth

delayed loading of managed MC++

This topic is 5244 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I''m using VC++ .NET 2003 Standard, and whenever I try launching a managed executable from within it, it takes 4-8 seconds for the program to load. When I start the program from explorer it loads instantly. What''s going on here?

Share this post


Link to post
Share on other sites
Advertisement
Are you running with debugging enabled (F5)? To run the program without debugging enabled press Ctrl+F5. Really though, even running with debugging enabled shouldn''t add 4-8 seconds at startup.

Share this post


Link to post
Share on other sites
Thanks...the debugging was it.

Any idea why it takes so long when I do it with debugging though?

Share this post


Link to post
Share on other sites
I am not completely sure to be honest. Obviously it has to do with the overhead of adding runtime debug information, but I don''t know about the specifics.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!