• Advertisement

Archived

This topic is now archived and is closed to further replies.

slow motion

This topic is 6386 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi... I have this problem... sometimes when I compile OGL programs they run really slow, like 0.5 FPS!!! I dunno what it is... but I really pi$$es me off. Sometimes it''s ok, sometimes it crashes after a while, sometimes it crashes right afeter i run my comp... I''m confised ! Maybe something is wrong with code ( tutorials too )? Maybe I need to reinstal my wINDOWS ? will somebody help me Pet

Share this post


Link to post
Share on other sites
Advertisement
Maybe it switches in SoftWare mode,

try to add some kind of blended square with a blending function the software renderer doesn''t support and look what it does when it start running slow

Share this post


Link to post
Share on other sites
yes folks we have a winner of the most unanswerable question of the month, but please keep sending those entries in , remember theres always next month to win and it could be you.
btw pet send me your code and ill take a look

Share this post


Link to post
Share on other sites
A way to see if it''s your fault or windows one, is to use two OS as I do, and use a crossplatform library to write only the code once and compile it on both OS.

Here''s my setup:
BeOS5 PE (http://free.be.com) / BeIDE (devtools.zip same URL)
Windows 98 SE / Visual C++ 6.0
SDL library (http://www.libsdl.org)

I code in C/C++ and OpenGL1.1

Hope it helps...

-* So many things to do, so little time to spend. *-

Share this post


Link to post
Share on other sites
he he he ... zedzeek, yes I know it sounds strange !!! About contest we should do like, whoever, before checkin the prev. answers, posts questions like : 3dmodels in ogl , should recive free newsletters from every member on this forum ... he he he...
ok enough... strange thing is that it happens even with tut lets say 6 ... I was thinking ( answer from my post before )that its a problem of lack of glDisableTextures...

but really I don''t know how to explain ... maybe hardware conflict ?
I thought that somebody had this before, and ... you know !
I''m waiting for some more answers ...


Pet

Share this post


Link to post
Share on other sites
I had a similar problem and the solution was to completely disable DualHead - MultiDisplay for my Matrox dualhead card whenever I wanted to run someones ogl program. The results we crazy, before disabling I''d get about 2fps, after I would have 60 - 80 or whatever... it was playable. So, If you are running two monitors try and disable your secondary completely...

ao

Share this post


Link to post
Share on other sites

  • Advertisement