Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Lotan

Extra thread when shutting down

This topic is 6645 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Whenever I write DirectX apps, I get an extra thread that: 1. If I shut down the program quickly after starting the thread exits with code -1. 2. If I wait for about 5 seconds or so, the game will pause for a split second(The thread exiting I''m assuming), and then the thread will exit with 0. Also, while using DirectPlay I seem to be getting a rogue thread that exits with -1 no matter what I do... Even if this is all of my code: void DPlay::Init(GUID appGuid) { m_appGuid = appGuid; CoInitialize(NULL); TEST(CoCreateInstance(CLSID_DirectPlay, NULL, CLSCTX_ALL, IID_IDirectPlay4A, (void**)&m_pDirectPlay)); } void DPlay::Release() { m_pDirectPlay->Release(); CoUninitialize(); } Any help would be greatly appreciated

Share this post


Link to post
Share on other sites
Advertisement

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!