Sign in to follow this  
Douchekop

Using Series 60 SDK v2.1 for programming Series 60 v1.0 Mobile Phones.

Recommended Posts

Douchekop    122
Is it possible to use the Series 60 v2.1 SDK to program C++ applications for series 60 v1 mobiles? I have VS.NET and the v2.1 SDK integrates with VS.NET, but will the compiled programs run under series 60 v1 mobile phones? What are important documents from Nokia to start with for the series 60 v1 mobiles? I want to port my software to other brand phones with symbian in the future, where should I look at? What are good general symbian recources? [Edited by - Douchekop on August 5, 2004 4:36:18 PM]

Share this post


Link to post
Share on other sites
adiash    187
Here
That should answer most of your questions regarding BC.

here is a list of sites you might also find helpful :
1. Symbian official site - contains lots of developer resources. click
2. NewLC - excellent tutorials click
3. Forum nokia pick me!
4. All about symbian click

Hmmm... that should be enough to start with

[Edited by - adiash on August 11, 2004 4:14:16 AM]

Share this post


Link to post
Share on other sites
OklyDokly    122
I couldn't get applications compiled in Series60 2.x to run on my NGage. Instead I had to install the series60 1.2 SDK. There's a little program called devices which allows you to switch between active SDKS.

Type 'devices -help' at your command prompt to get more info. You may find however you get emulator problems when older versions are installed (I think I did).

Share this post


Link to post
Share on other sites
adiash    187
Were you using any SDK 2.1 specific API?
Anyway, the more logical thing to do if you want to target a broad range of phones, is to work with the older SDK (1.X).
You have more chance of an app compiled using 1.X working on 2.X than the other way around.
In any case, full inter-platform compatability is something that Nokia simply doesn't guarantee. The only way of being sure that your app will work on all paltforms is to compile each with the corresponding SDK.

Share this post


Link to post
Share on other sites
OklyDokly    122
I think it was 2.0 I originally used for series 60. It was some time ago I tried it though, when I was still learning Symbian.

By the way, as a little off topic, will the 7650 run an application compiled using the 1.2 API? I've heard rumours that it doesn't support the CDirectScreenAccess class ...

Share this post


Link to post
Share on other sites
adiash    187
Direct screen access is actually a symbian feature rather than a UI feature. AFAIK, if the phone operates on Symbian 6.1 or above, you should be fine.
Can't say that I tested it on the 7650 though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this