Sign in to follow this  

Linux 2.6+nvidia drivers issue

This topic is 4859 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am runnint linux kernel 2.6 (slackware 10) on my computer and am having trouble with the latest linux drivers...When I install them, everyhing works ok until it is time to switch to a virtual console, or kill X. When I do this, the computer puts large dots of a few different colors on the screen and no text is there (the dots are obviously the text, but it is badly distorted...). It look like the video memory were somehow corrupted...Anyway, has anyone experianced this? Is there any solution? My brother can get his nvidia drivers working fine under the same kernel...

Share this post


Link to post
Share on other sites
Most likely the 4k stack's issue, in your kernel config :



goto /usr/src/linux

do make menuconfig



then go



kernel hacking --> Use 4Kb stacks instead of 8Kb stacks



and turn it off



The latest nvidia drivers also should have support for this feature (I not sure here), but if you havn't allready tried the latest drivers go try them.

Share this post


Link to post
Share on other sites
Hahahha...Thanks, but it seems I was wrong...I am running 2.4.26 [sad] and that feature is not avaliable in this version...What else could it be? I know I have gotten 2.4.26 running with nvidia drivers...

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
I had a problem similar to this a while back. It was caused by the console frame buffer using the wrong driver.

If you have the frame buffer enabled in the kernel, try disabling it or switching to the VESA driver.

You never know, it might work

Share this post


Link to post
Share on other sites
The solution to your problem is:

go to root (by su or sudo)

open up your /etc/lilo.conf by

#gedit /etc/lilo.conf, or

#pico /etc/lilo.conf

What ever suits you,

Then change the line that says:

vga=773 (or what have you)

to

vga=normal

exit, go to console (make sure you're in root again)

type /sbin/lilo

That should update your lilo

Restart your computer, and you're set to go.

Cheers,
Cipher3D

Share this post


Link to post
Share on other sites
Last time I tried it the NVidia drivers seem to assume the console is running in normal VGA mode, and switch to that instead of whatever VESA mode you might really be running, thus buggering everything up.

Share this post


Link to post
Share on other sites
Sign in to follow this