Jump to content
  • Advertisement
Sign in to follow this  
TomschikSimon

Texture3D sample: Bug

This topic is 5200 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am using the Texture3D-sample from the DirectX8.1 SDK. The sample detects the right resolution of my videos, but on the created texture, the picture is surrounded by a black border. How can I fix this.

Share this post


Link to post
Share on other sites
Advertisement
I think this is caused by the texture adressing mode. IRC you have to set it to clamp but I'm not sure.

Share this post


Link to post
Share on other sites
I don't think it is the texture adressing. The sample creates a texture with the right resolution, so the video must fill the complete texture. Here is an example:


And that would be right (made with Virtual Dub):

Share this post


Link to post
Share on other sites
It's quite possible that the black border, at least on the left and right, are overscan from the video signal. It may very well be what your video capture card delivers through the capture application.

The keyword is "overscan".

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!