Jump to content
  • Advertisement
Sign in to follow this  
CodeTitan

CGI Errors

This topic is 5174 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I tried to set CGI up for my Apache server. I use Windows, btw. I tried to run a simple .cgi script at http://localhost/index.cgi, but I got a 403 Forbidden error. I edited the httpd.conf file to +ExecCGI, but I still get this error. I restarted Apache. Has anyone got this error before, or better yet, knows how to fix it? I know it's not an error with the CGI file.

Share this post


Link to post
Share on other sites
Advertisement
The directory your script is in might need more global permissions. The default "rule" is allow from none / deny from all. Then you expand that with rules that open up certain parts of the filesystem. Here is a snip from my overly permissive desktop setup:


<Directory /home/leiavoia/www/sites/os/>
Options Indexes Includes FollowSymLinks MultiViews ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>



On UNIX, you should also check permissions on the program (try 755) and on the folder it's in.

Share this post


Link to post
Share on other sites
You're welcome ;-) I wasted 7 hours of my life on that very same problem. I hope no one has to suffer the same way.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!