Sign in to follow this  

CGI Errors

This topic is 4866 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I tried to set CGI up for my Apache server. I use Windows, btw. I tried to run a simple .cgi script at http://localhost/index.cgi, but I got a 403 Forbidden error. I edited the httpd.conf file to +ExecCGI, but I still get this error. I restarted Apache. Has anyone got this error before, or better yet, knows how to fix it? I know it's not an error with the CGI file.

Share this post


Link to post
Share on other sites
The directory your script is in might need more global permissions. The default "rule" is allow from none / deny from all. Then you expand that with rules that open up certain parts of the filesystem. Here is a snip from my overly permissive desktop setup:


<Directory /home/leiavoia/www/sites/os/>
Options Indexes Includes FollowSymLinks MultiViews ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>



On UNIX, you should also check permissions on the program (try 755) and on the folder it's in.

Share this post


Link to post
Share on other sites

This topic is 4866 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this