Jump to content
  • Advertisement
Sign in to follow this  
atomhamster

sony ericsson on device debugging

This topic is 5138 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

does anyone here have additional information about on device debugging with the sony ericsson sdk? this is my ant-task: <target name="run on device" description="none"> <exec executable="D:/dev/Java/SonyEricsson/J2ME_SDK/OnDeviceDebug/bin/emulator"> <arg line="-classpath ${project_home}/bin/build/jadjar/${app_filename}.jar"/> <arg line="-Xdescriptor:${project_home}/bin/build/jadjar/${app_filename}.jad"/> <arg line="-Xdebug"/> <arg line="-Xrunjdwp:transport=dt_socket"/> <arg line="-Xrunjdwp:address=5005"/> <arg line="-Xdevice:SonyEricsson_K700"/> <arg line="-Xjam:run"/> </exec> </target> i use a k700i and IRDA. when i start the "pseudo" emulator for device debugging, i get a connection and im asked to select an "entry-point" from a list of installed games. java is started, but no screen is painted. after a minute or so, the devices tells me about an "invalid application". the "pseudo" emulator (PC) is stopped and the application is deleted (device). this is a bit odd. im chasing an error which freezed the phone without visible cause and i think this might be a way to find it? any suggestions?

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!