Sign in to follow this  

CGSL speed problems

This topic is 4860 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello everyone! please help me on this one, since i've been breaking my head for quite a while now... :) i am working on a game right now, i have added recently per-pixel-lighting using CGSL. It looks great, but i have one big problem - speed... before i tell my specs i must say that Doom3 runs pretty fluid in my computer. my specs are: 1.5 GHZ cpu memory - 384 mega nVidia FX 5900 what i do is much like doom3: i have diffuse map, normal map and specular map. currently i am rendering a checkers board model and 26 quake3 models (with auto generated normal and specular maps). my FPS is ~30 right now. if i change my Fragment-Program to only do the most basic thing (just display the diffuse texture) i get ~50 FPS. i followed this diagram: http://legion.gibbering.net/zedus/bottleneck.gif and it seems that i am FP limited. here are the FP / VP i use http://legion.gibbering.net/zedus/BumpMapFP.cg.txt http://legion.gibbering.net/zedus/BumpMapVP.cg.txt does anyone have any idea how to change/optimize the FP to make it faster?? i tried using halfs instead of floats inside the FP and it didn't change anything. thanks for your time. :)

Share this post


Link to post
Share on other sites

This topic is 4860 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this