Sign in to follow this  
GENTS

Strange ALT-TAB & Input problem!!!

Recommended Posts

Why when I do ALT+TAB during the execution of my 3D app and then I come back in this one, my std input is away?! The only key that work is the ESCAPE!!! And other keys?! Why I can't use other keys?! I can see all the enviroment, meshes, etc. but my keybord doesn't react when I press keys except of ESCAPE... THANKS FOR REPLIES ^__^ Byez,

Share this post


Link to post
Share on other sites
Well, when you press Alt-Tab, your App loses focus, and therefore would not receive the key input. Try pressing Alt-Tab, then clicking on it, see if that works.

Other than that, maybe you lost and reset your D3DDevice, and left something out of the code for that.

I would look at how you handle keypress events because I'm sure the answer is in there - what do you differently between the routines for escape and all the other keys? I'll bet that you have two separate routines for the escape key (one that you probably forgot about) that is throwing you off.

In any case, happy bug hunting season [wink]...

Share this post


Link to post
Share on other sites
Ok, its not an input problem, but I can't find an useful code to reset my device...

Who can help me?!

I've tried a lot of oced, releasing and re-loading all data or only a part(D3DPOOL_DEFAULT)

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this