Jump to content
  • Advertisement
Sign in to follow this  
DirectXFreak

D3DDEVTYPE_REF returns D3DERR_NOTAVAILABLE!

This topic is 5151 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, DirectX 9.0 doesn't seem to support the REF device for my system! All of the demos on the sdk only allow the HAL device, and when I try hardcoding REF into it, it fails! DirectX 8.0 allows me to use it, so what's up?

Share this post


Link to post
Share on other sites
Advertisement
1) Go to the DirectX control panel (Start->Settings->Control Panel).

2) Select the Direct3D tab.

3) Enable the "Enumerate Reference Rasterizer" option.


If you don't have a DirectX control panel applet or it's disabled/greyed out, then make sure you install the latest SDK and not just a new runtime! (i.e. if you install a DX9.0 runtime over a DX8.0 SDK you can get these kinds of problems because the REF device, control panel applet etc are only for development so only come with the SDK)

Share this post


Link to post
Share on other sites
REF is only available if you have the debug runtime installed. Also, the debug runtimes might only work if they're as upto date as your retail runtimes (much like the Control Panel option is only available if the debug runtimes are up to date).

The debug runtimes, if installed and up to date, can be enabled by going to the DirectX item in the control panel, and choosing them in the D3D tab.

edit: D'oh beaten to it...

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!