Jump to content
  • Advertisement
Sign in to follow this  
psycho_munkey

cant get projects working in DX

This topic is 5175 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I just downloaded the latest SDK and I tried to run the project I had been working on on the previous SDK and i got the folllowing error: Linking... d3dx9.lib(fastftoa.obj) : error LNK2001: unresolved external symbol __aulldvrm LIBCD.lib(crt0.obj) : error LNK2001: unresolved external symbol _main Debug/Game.exe : fatal error LNK1120: 2 unresolved externals Error executing link.exe. Game.exe - 3 error(s), 0 warning(s) I also get this when compiling the DX samples that came with the new SDK (summer 2004)

Share this post


Link to post
Share on other sites
Advertisement
  • Do your drivers support Dx9? Try updating them.
  • Was it installed correctly? Try reinstalling it.
  • Do the already-compiled samples work? If they do, then it's a problem with the complier.

Share this post


Link to post
Share on other sites
Does the compiler know the directories to search for header and lib files? Sounds to me it can't find them.

Share this post


Link to post
Share on other sites
LIBCD.lib(crt0.obj) : error LNK2001: unresolved external symbol _main

fairly sure this means that either you made a console project when you meant to do a windows project & thus you didn't code a main function (or that you meant to do a console one & miss typed main)

Share this post


Link to post
Share on other sites
Quote:
Original post by psycho_munkey
d3dx9.lib(fastftoa.obj) : error LNK2001: unresolved external symbol __aulldvrm


and this sounds like there's another library to which you need to link. could very likely be a pathing issue (i.e. your old project is set to use your old directX installation directory and you need to convert it to the new one)

-me

Share this post


Link to post
Share on other sites
I had dx9 sdk and thats what i used to make my projects in the first place.

I had my computer wiped but i kept the project on disc. I reinstalled the sdk and then i got this problem.

when you install, it sets the directories on installation (MSVC++ .0)

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
could someone plz help me out

Share this post


Link to post
Share on other sites
Make sure of the following...
1. Open Microsoft VC++
2. Tools -> Options -> Directories
3. Drop down menu to "Include Files"
4. Make sure the first line in the box is the correct path to the DX include files(must be the first line, order matters!) The default is C:\DXSDK\Include
5. Drop down menu to "Library Files"
6. Make sure the first line in the box is the correct path to the DX library files(must be the first line, order matters!) The default is C:\DXSDK\Lib
7. If you changed anything hit OK
8. Try to compile again

If your paths were correct then try this:
1. Open your project
2. Project -> Settings -> Link
3. Look in the box labeled "Project Options"
4. If somewhere in that box it says /subsystem:console change it to /subsystem:windows
5. If you changed anything hit OK
6. Try to compile again

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!