Jump to content
  • Advertisement
Sign in to follow this  
chandras

ARB_VERTEX_PROGRAM

This topic is 5053 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hi all, i've a problem with this extension...(maybe it's my fault, i'm not experienced): i've tried to write my first vertex programs in some simple contests, but even there're no errors (using glGetString(GL_PROGRAM_ERROR_STRING_ARB);) primitive vertex won't show (with GL_ARB_PROGRAM_VERTEX enabled). If i disable the extension everything works; i try standard vertex programs (downloaded with some tutorial) which replace part of vertex pipeline, some of downloaded examples don't work, a few of them work ( i don't know why :( ); is my ati card (9600) responsible for this ? do someone have any suggestion ? thanx to all (and sorry for limited english)

Share this post


Link to post
Share on other sites
Advertisement
It could be a mistake in pipeline configuration. It's hard to say from just what you've said so far; can you maybe post some code or a more specific explanation of what you're doing?

Share this post


Link to post
Share on other sites
i've tried many simple vp downloaded with some tutorials, but all i get is black screen '-' i'm in despair

isn't supposed that i can see right trasformed coordinates with this vp ? (or not) i get no error but nothing appears, if i disable the extension everything goes right


!!ARBvp1.0
ATTRIB iPos=vertex.position;
ATTRIB iColor=vertex.color;
ATTRIB iTex0=vertex.texcoord[0];
PARAM mvp[4]= { state.matrix.mvp };
OUTPUT oPos=result.position;
OUTPUT oColor=result.color;
OUTPUT oTex0=result.texcoord[0];

DP4 oPos.x, mvp[0], iPos;
DP4 oPos.y, mvp[1], iPos;
DP4 oPos.z, mvp[2], iPos;
DP4 oPos.w, mvp[3], iPos;

MOV oColor,iColor;
MOV oTex0,iTex0;
END

Share this post


Link to post
Share on other sites
3 days of continous changes and tests, and the problem was that i put the function for deleting programs before message pump in winmain, i want to kill my self, thanx anyway ^^

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!