Jump to content
  • Advertisement
Sign in to follow this  
archaos

OpenGL Newbie lighting kink

This topic is 5051 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello! I'm having some strange problems with my program. I've loaded in a model with normals, but the lighting seems wrong. I draw the normals and they seem to be correct, but when I turn on the light, well... see for yourselves. Any hints for a OpenGL-newbie? :) http://www.d.kth.se/~bartek/agi/Weird.rar

Share this post


Link to post
Share on other sites
Advertisement
You're more likely to get a useful reply if you post specific info and relevant code in your post, ie tell us how you setup your lighting, normals etc, maybe post a screenshot to illustrate the "wrong" lighting (whatever that means). Most people aren't going to bother downloading your program to test it.

Share this post


Link to post
Share on other sites
Without downloading I can guess your not setting the position of the light after you set up your camera.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!