Jump to content
  • Advertisement
Sign in to follow this  
TheBunny

Allegro, threading trouble with pthreads.

This topic is 5479 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

At the top of my main.cpp file i have: #include <pthread.h> #include "allegro.h" This gives me tons of errors in atleast 4 different allegro header files that all say: "using typedef-name `BITMAP' after `" Then at the bottom of about 40 of these errors there is: "declaration of C function `int WinMain(void*, void*, char*, int)' 933 C:\Dev-Cpp\include\winbase.h previous declaration `int " I think that pthread trys to load one of the windows files, winbase.h, and because allegro and windows are loaded at the same time, and both have those WinMain functions, it gets messed up... How could i fix this? [Edited by - TheBunny on September 22, 2004 5:33:18 PM]

Share this post


Link to post
Share on other sites
Advertisement
BTW i got the allegro and phreads source from the cd with "Game Programming All In One" 2nd edition. By Johnathan S. Harbour.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!