Jump to content
  • Advertisement
Sign in to follow this  
Xilo

Linking Error with IDirect3D9

This topic is 5474 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

For some reason, whenever I try to compile a DirectX app, I keep getting this error: error LNK2001: unresolved external symbol "struct IDirect3D9 * __stdcall Direct3DCreate9(unsigned int)" (?Direct3DCreate9@@$$J14YGPAUIDirect3D9@@I@Z) What in the world is wrong? I've never gotten this error before. I'm using Summer 2004 SDK.

Share this post


Link to post
Share on other sites
Advertisement
sounds like you forgot to add the directx libs directory to your project settings.

Another posibility is you have an old directx version's libs with the new version's includes.

That error means your including the .h file but the .cpp file, (or in this case .lib as it's precompiled) isn't anywhere in the project

Share this post


Link to post
Share on other sites
Nope, all the necessary directories for library and header files are setup correctly. I can't have old versions either, because I had reinstalled Windows about a month ago and installed only the Summer 2004 SDK.

Share this post


Link to post
Share on other sites
There shouldn't be any problems then.
Just to make sure (I don't want to annoy you) - have you checked
Tools/Options/Projects/VC++ Directories to have your DXDSDK include and library paths to as the first entries in the list?

Share this post


Link to post
Share on other sites
I just said I did in a few posts above. Ug, this is really annoying. I've never had this problem before -_-

Edit: Fixed by messing with linker options. But, I don't know why I'd have to manually set it. I've NEVER had to before.

Share this post


Link to post
Share on other sites
Quote:
Original post by Xilo
Edit: Fixed by messing with linker options. But, I don't know why I'd have to manually set it. I've NEVER had to before.

This sounds a bit odd to me. You always have to add the d3d libs to the project settings. They won't just magically appear there [smile].

Anyway, good to hear you fixed that.
Pat.

Share this post


Link to post
Share on other sites
I remember why I never had to. I forgot that the new update took out the DirectX templates.

Anyone have just the DirectX empty project template to share?

Share this post


Link to post
Share on other sites
It's still in there, it's just not an AppWizard any more - it's the "EmptyProject" sample. You just make a copy of the sample and begin changing it.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!