Jump to content
  • Advertisement
Sign in to follow this  
benjamin bunny

Try my shadows demo

This topic is 5492 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Advertisement
It won't run on the crappy computers at my college

Pentium 4 1.6ghz
512 mb ram

Radeon 7000 64mb ram

the error I get is:
FATAL ERROR :
Your graphics card/driver does not have support a required capability:

ARB_vertex_buffer_object extension required

Please see readme.html for more information

Function : MainGM::checkCaps
File : .\MainGM.cpp
Line : 890

Share this post


Link to post
Share on other sites
Quote:
Original post by Pipo DeClown
Anyway I can emulate it or something?


Try this. Just put the exe in the cathedral main dir and run it. It should work. I think I disabled all the SSE parts, but it's a bit hard to tell unless I try it on a non-SSE machine.

Share this post


Link to post
Share on other sites
About 5fps on a GeForce FX 5600. This card has a horrible fillrate, but still the demo's on the slow side (could have something to do with the shaders, maybe?)

Other than that: The shadows look great :-) I noticed one tiny glitch in the cathedral mesh (left hand side as seen from the entrance). Finally, the scene is a bit dull with the brownish textures tiled all around - some more detailed textures would have done wonders.

Share this post


Link to post
Share on other sites
Yeah, ARB_fragment_program is notoriously slow on geforce FX cards. Nothing I can do about that. ATi cards around have no such problems. Even my mobility 9600 runs it at ~25fps.

Share this post


Link to post
Share on other sites
Quote:
Original post by benjamin bunny
Yeah, ARB_fragment_program is notoriously slow on geforce FX cards. Nothing I can do about that. ATi cards around have no such problems. Even my mobility 9600 runs it at ~25fps.


Yes, but I substituted the fp with one that just returns white color, and it still doesn get any higher than 17-18 FPS. It must be the shadows. Btw,you don't render the shadow volumes with fp enabled, right?

Share this post


Link to post
Share on other sites
After I confirm(or deny, for that matter) full screen mode I get:

Error loading shader: vertex shader attach error

Function : Mirage::ShaderManager::loadProgram
File: \BenMobile\My Documents\Projects\democd\DemoCD\source\modules\ShaderManager\ShaderManager.cpp
Line : 146

Immediately after this it General protection faults.


Specs:
Pentium 4 3.0ghz
Geforce FX 5700
512mb RAM
Intel PBZ motherboard

Share this post


Link to post
Share on other sites
Quote:
Original post by mikeman
Quote:
Original post by benjamin bunny
Yeah, ARB_fragment_program is notoriously slow on geforce FX cards. Nothing I can do about that. ATi cards around have no such problems. Even my mobility 9600 runs it at ~25fps.


Yes, but I substituted the fp with one that just returns white color, and it still doesn get any higher than 17-18 FPS. It must be the shadows. Btw,you don't render the shadow volumes with fp enabled, right?


Nope, ABB_fp, ARB_vp, texture, etc are all disabled when rendering the shadow volumes, as you would expect. Shadow volumes are very fill-rate intensive though. I'd be surprised if you can get even 5-6 fps in Doom 3 on that card at 1024x768.

You can disable shadows though by setting the castShadows attribute in config files/init.xml to 0 for each light.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!