Jump to content
  • Advertisement
Sign in to follow this  
Tubular

D3D8.DLL missing from DX9 Redist???

This topic is 5464 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have a slightly disturbing question. Several of my players have complained that my game does not run, showing instead the error message "D3D8.DLL not found," etc. I'm actually not sure about the format or contents of the rest of the error, because I haven't seen it myself. My game was compiled for DX8, true, but those people who are complaining not only claim to have DX9 installed, they are also the sort of people I would expect to know better. Does this mean DX9 has some problem being backwards compatible with DX8 games? I don't think I've ever used a computer that hasn't had DX8 installed on it before DX9 was installed, so I haven't been able to test this, but it's a worrying possibility. Could this also be a problem with the way I've linked my program? I'm including a whole slew of DLLs, DInput8, D3D8, D3Dx8, Dplay, Dsound, etc, using MSVC++ 6.0. But it seems to work on the vast majority of machines, including those with DX9 installed. Has anyone heard of a problem like this before? Please let me know if there's anything I can do about it. Thanks.

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!