Jump to content
  • Advertisement
Sign in to follow this  
Keba

Info: "Failed to create driver indexbuffer"

This topic is 5459 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

got this info in debug mode: "Failed to create driver indexbuffer" i searched on google and found that because it was an info it was nothing to worry about, true? should i just ignore this? I still got a valid indexbuffer after IDirect3DDevice::CreateIndexBuffer() And does this mean that indexbuffers aren't supported in hw? i got a ATI 9800 PRO and using DX 9 summer update 2004 / thanks

Share this post


Link to post
Share on other sites
Advertisement
True, that's nothing you should be worried of. In fact, this is the device driver trying to create an hardware index buffer and failing to do so. At least, that's what they say on the DirectX mailing list.

As of whether yes or no the ati 9800 does support HW index buffers, I cannot tell you that. I had a look at the msdn doc for the caps but couldn't find an entry that would allow you to check that. Could be that I've missed it somewhere.

Share this post


Link to post
Share on other sites
IIRC, the Radeons 8500+ *had* support for HW index buffers, until they were disabled in the drivers for some reason (don't really recall which driver release did this).

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!