Jump to content
  • Advertisement
Sign in to follow this  
danger_boy_13

OpenGL OpenGL version

This topic is 5458 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Is there that much of a difference between programming in different versions of OpenGL? I have a Geforce FX 5600 and it only supports up to 1.4, and I am starting to get into OpenGL programming. I was just curious.

Share this post


Link to post
Share on other sites
Advertisement
Once you move beyond 1.1 you will have to learn to load extensions but dont expect to reach that point for awhile. Once you do however it wont be much diffrent. Here is one of the best (if not the best) opengl tutorial on the net:
NeHe They have tutorials that axplain how to load extensions when you reach that point along with the basics.

Share this post


Link to post
Share on other sites
First, the reason your FX only supports 1.4 is because you need to update your drivers.

Generally, with Windows you will always code for 1.1 with extensions. You can code for other versions on other platforms, but most people stick to coding 1.1 and extensions. It's a good common denominator to work with.

Share this post


Link to post
Share on other sites
I like GLee a lot as extensions loading system, and it's done by our very own moderator, benjamin bunny.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!