Jump to content
  • Advertisement
Sign in to follow this  
Kasracer

I am confused. Setting up OpenGL with C++

This topic is 5400 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I've seen several different things so far as to how to setup OpenGL to work in VC++ 7 and MinGW. None are working for me. When I include gl.h and/or glut.h in my projects, I get a crapload of errors from within the headers and then it gives up. What do I have to do to make it work correctly with C++ in either compiler? I definately don't want to go back down to C.

Share this post


Link to post
Share on other sites
Advertisement
It shouldn't make any difference if you are using C or C++. You need to provide a lot more info, though Instruo makes a good guess.

Share this post


Link to post
Share on other sites
Wow, thanks. I feel really stupid right now... I didn't even see that listed anywhere. No wonder I was having problems.

Thanks, lol

Share this post


Link to post
Share on other sites
An alternative is to #include <GL/glut.h> (whether or not you actually _use_ glut is irrelevant). It will include the gl headers just fine without pulling in the windows header.

Share this post


Link to post
Share on other sites
Quote:
Original post by wendigo23
An alternative is to #include <GL/glut.h> (whether or not you actually _use_ glut is irrelevant). It will include the gl headers just fine without pulling in the windows header.
I'm using glut and it gave me the errors without windows.h.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!