Sign in to follow this  

problems with texture smooth movement

This topic is 4819 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I load some textures (1024*64), and then I move them to the left to make something like a scrolling text (I know this isn't the "professional" way to do this...). I use time related movement, something like: ... float pos=0.0f; float speed=-2.0f; //units*secs glTranslatef(pos, 0, 0); pos+=lastFrameTime*speed; ... I think this is the smoothest possible movement code... but on my pc (P3-700Mhz with GeForce2 GTS) it's not very smooth... I've tried to render only this stuff and it's the same... Why? Maybe it's because I must render the texture in more than a simple large GL_QUAD? Or maybe because I render the texture too close to the eye/screen ? P.S. is it better to use units*secs or units*millisec as unit for speed? The scroll must be quite slow but fluently to be readable...

Share this post


Link to post
Share on other sites

This topic is 4819 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this