Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

TheLabRat

Material Properties Not Working (GL)

This topic is 6496 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

If I change the default diffuse reflection of materials in OpenGL, nothing is shown on the screen, no matter how light I make the scene. Even setting the diffuse reflection to full white and the light to any color in the spectrum does nothing. Also - all other lights seem much darker than LIGHT0, even if I turn up their settings to max white. Why? Chris

Share this post


Link to post
Share on other sites
Advertisement
Make sure you're rendering the materials & lighting on. I'm pretty rusty on OGL, but I remember a command & a flag that switches from using the vertex colors to the material properties and another that turns the lights on.

Are the other lights the same distance away?
Turn up the ambient light and see if it changes.

also, many older video cards and older video drivers dont do ogl very well (nor dx for that matter).

Edited by - Magmai Kai Holmlor on October 7, 2000 4:16:13 PM

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!