• Advertisement
Sign in to follow this  

Debuging problem in MSVC 2003

This topic is 4867 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am used to use msvc 6.0, now I have version 2003, but the debugger doesn't work weel for me. When I want to debug instruction by instruction in a function, you user hotkey F11, well, but in my programs, I can only debug in this way functions of the standart libs (string, stdio ...) but in my own functions doesn't work (it works like F10). thnx

Share this post


Link to post
Share on other sites
Advertisement
Do you mean you installed the VC Toolkit, or you got VC 2003?

Share this post


Link to post
Share on other sites
Make sure you're using the "Debug" configuration(or set it up so you have debugging symbols even in "Release", but that's another story).

Share this post


Link to post
Share on other sites
You can only debug into functions that you have the source code, and pdb's for at a source level. ie you can't debug 3rd party calls or windows calls.

Hope that helped

Cheers
Chris

Share this post


Link to post
Share on other sites
sorry, I explain it wrong, it's:

and it debug good except for F11 - debug into functions, and only it works into functions NOT done by me (like memcpy, printf ...).

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement