Jump to content
  • Advertisement
Sign in to follow this  
aftermath

MSVC lib problems? This is driving me nuts

This topic is 4993 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

saver.obj : error LNK2001: unresolved external symbol __RTC_Shutdown saver.obj : error LNK2001: unresolved external symbol __RTC_InitBase I've been having this small linker error every time I start a new project. This also happends when creating a default Win32 app in MSVS 2003. I have the Platform SDK and MS DDK for Win Server 2003 installed. Does anyone know if I have to link with a sertain library? I can't seem to find any information. Even Google comes back with NO results for "RTC_Shutdown" or "RTC_InitBase" Thanks.

Share this post


Link to post
Share on other sites
Advertisement
I'm really not sure, but it must have something to do with your build options, have you changed anyhting recently. Are you by any chance including saver.obj in all you projects from the linker objects?

Sorry if this is useless or obvious or just entirely wrong...

Share this post


Link to post
Share on other sites
Hmmmm ...
...


mmm ...



Setting "Basic Runtime Checks" to "Default" helps. Setting it to somthing other then default gives me the error. So does this mean I'm not getting basic runtime checks?

Share this post


Link to post
Share on other sites
Perhaps your somehow including saver.obj which was compiled with the runtime checks in a different setting so it can't find the functions that it's looking for. The compiler probably defines a startup and shut down function for runtime checks that is different dependent on the mode and the object files needs to link with a different function.

Edit: nevermind this part...huh that's wierd stuff.

Share this post


Link to post
Share on other sites
Sounds like you are including something that requires an external library. Whatever it is, it must be missing from your linker options. Try removing any 3rd party libraries. Check for them under Tools->Options->Projects->VC++->Directories.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!