Jump to content
  • Advertisement
Sign in to follow this  
Freakdesign

to much Stairs in Edges

This topic is 5132 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi at all! my project is written in VB.Net and is a kind of Editor actually. i can place several objects in a landscape an modify them, but i dont know how to make "nice edges" look here: screenie1 screenie2 screenie3 the edges looks like stairs to the hell. more distance causes "hidden" Faces to "blink" i tryed to switch on the anti-aliasing feature from the driver-setup of my GraphicsHardware, but this causes the system to die a horroble death. i hope someone knows a tricky renderstate who deals with that aliasing of ObjectEdges, a technic to avoid this or just a helpful link this is my RenderStatesetup: Device.Lights(5).Type=LightType.Point Device.Lights(5).Enabled = True Device.Lights(5).Range = 10000000 Device.Lights(5).Position = TheSonnensystem.Jupiter.Position'.X + tgd.X * 400 device.Lights(5).Direction=new Vector3(0,0.1,0) Device.Lights(5).Attenuation0= 0.1 Device.Lights(5).Attenuation1= 0.000001 Device.Lights(5).Update() device.RenderState.Ambient = System.Drawing.Color.FromArgb(128,128,128) Device.SamplerState(0).MinFilter = TextureFilter.Linear Device.SamplerState(0).MagFilter = TextureFilter.Linear Device.SamplerState(0).MipFilter = TextureFilter.Linear Device.RenderState.CullMode = Cull.CounterClockwise Device.RenderState.Lighting = True Device.RenderState.ZBufferEnable = True Device.RenderState.ZBufferWriteEnable = True Device.RenderState.FillMode=FillMode.Solid Device.RenderState.ShadeMode=ShadeMode.Gouraud 'default Col.Ops und Col.Argues Device.TextureState(0).ColorOperation = TextureOperation.Modulate Device.TextureState(0).ColorArgument1 = TextureArgument.TextureColor Device.TextureState(0).ColorArgument2=TextureArgument.Diffuse thanks in advance... [Edited by - Freakdesign on October 25, 2004 7:58:06 AM]

Share this post


Link to post
Share on other sites
Advertisement
That's Z-buffer fighting/thrashing/other random term...

But basically the resolution of your Z-Buffer is far too low, which means one of two things:

a) Your far clip plane is out way too far. Bring it in a bit (Maybe to about 1000 to 5000 if it's anything above that)

or

b) You have your depth buffer set to 16 bit. Try setting it to 32-bit and see if it makes a difference.

Share this post


Link to post
Share on other sites
Thx to you PlayfulPuppy!

it was the depthsetting of the BackbufferStencilFormat, with the following present.params it works really good(last was not set before so it takes Depth.Formar.D16 by default):

presentParams.MultiSample=MultiSampleType.NonMaskable
presentParams.MultiSampleQuality=2
presentParams.SwapEffect=SwapEffect.Discard
presentParams.EnableAutoDepthStencil=true
presentParams.AutoDepthStencilFormat = DepthFormat.D24X8

but my average fps goes down a bit (20%), is this a tribute to quality?

greets
--------

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!