• Advertisement
Sign in to follow this  

Smooth Mesh

This topic is 4833 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi , WRT meshes. A mesh created in 3dsmax that is a cylinder - looks quite smooth and u dont see the curved edges looking jagged . When I convert the mesh to an .X file and display in a direct3d program - the curved edges look jagged - almost like a NON-antaliased line ... Any reason for this ?? Even if the mesh has alot of vertices , u can still notice it. Any help would be greatly appreciated

Share this post


Link to post
Share on other sites
Advertisement
I think that I've solved the problem
I've upped the sample rate to 6x on my Radeon and its seems to help.
FPS has dropped by 20 though !!!

Is this the correct solution ?

Share this post


Link to post
Share on other sites
I think its to do with how the normals are calculated.
Averaging them for each vertex creates smoother lighting?

Share this post


Link to post
Share on other sites
I'm not certain that I understand the problem, AND I'm using an ancient version of 3ds Max (r3), but when you create geometry in 3d max r3 there's a Smooth option in the parameters window which is checked by default. I'm not sure what it does but I assume it's adding vertices to create a smoother image. I see geometry in 3d max the way it will appear after an .x file conversion if I UNCHECK THE SMOOTH BOX.

Share this post


Link to post
Share on other sites
Have D3D recalculate the normals. That's the best way to get a smooth look if your modelling tool doesn't export proper normals.
Conclusion: Use D3DXComputeNormals.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement