Jump to content
  • Advertisement
Sign in to follow this  
ade-the-heat

OpenGL new graphics card-now cylinders are bad

This topic is 4975 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

check link below: http://myweb.tiscali.co.uk/3drocknroll/badcylinder.jpg The cylinders have sort of like spots or white ringson them, they were smooth colored before. Before I had a intel exteme graphics, now I have a new Radeon 9600se card. I've checked for opengl errors and there are none. Here's the code to draw the cylinders: #define TURRET_WIDTH 4 #define TURRET_LENGTH 20 for each cylinder: ===================== gluQuadricDrawstyle(turret, GLU_FILL); gluQuadricNormals(turret, GLU_SMOOTH); //do translation+rotation //draw each cylinder like this: gluCylinder(turret, 4, 20, 20, 10, 10); ======================= Any ideas how to get rid of the blotches... I have several other graphics type problems now I have a new card as well... cheers Ade

Share this post


Link to post
Share on other sites
Advertisement
They look like bad normals to me - it's the right colour and the right shape, it just has the wrong amount of lighting on pairs of vertices. You could try drawing the normals?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!