Sign in to follow this  

[symbian] armi compilation woes

This topic is 4811 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I type this:
bldmake bldfiles
abld build armi urel
but i get this:
ABLD ERROR: "\Symbian\7.0s\Series60_v21\EPOC32\BUILD\DOCUMENTSPlatform.pm" not yet created
BEGIN failed--compilation aborted at C:\Symbian\7.0s\Series60_v21\epoc32\tools\abld.pl line 144.
even if i type: abld build wins udeb, it gives me the same error. but inside msvc++.net compiler, i can compile for wins udeb and urel, however, i cannot compile for armi inside msvc++.net! any idea why this error happens? Thanks.

Share this post


Link to post
Share on other sites
That kind of error usually mean that some paths (or EPOCROOT) weren't set correctly. Most probably SDK was not correctly installed. Another pssible reason - too long paths. Nokia SDK can not work if paths are too long - try use short names for directories and use subdirectory as few as possible. Are you using Nokia SDK ?
Aslo check your bld.inf and abld.bat files. BTW have you checked if SDK examples can be built ?

[Edited by - serg3d on November 11, 2004 4:35:37 AM]

Share this post


Link to post
Share on other sites
i moved the project folder to one that contains no whitespace in the directory name, and it works now. Thanks!!! :)

Share this post


Link to post
Share on other sites
Sign in to follow this