• Advertisement
Sign in to follow this  

Please test my first shader test app!

This topic is 4849 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Advertisement
vsync off, no bloom : min=93 max=129 fps
vsync off, bloom on : min=11 max=11.25 fps

Hardware : P4 2.40 GHz, RAM 512 MB, GeForce FX 5200 Ultra 128 MB AGP 4x
Software : your app in fullscreen, using NVIDIA 61.77 driver on top of WinXP Home SP1.

btw, I think there's a bug in your vsync init. When I start the program, the framerate is locked to 60Hz (+/- 1%) and when I hit F3 it's still locked to 60Hz, and when I hit F3 again the framerate is unlocked (unleashed !). Then whenever I hit F3 it toggles vsync correctly.

Share this post


Link to post
Share on other sites
Runs fine on my amd 1700+ and 9700 pro.

Got a link to an explination of how that effect is done?

Share this post


Link to post
Share on other sites
Works great!

Win2K
ATI Radeon 9800pro 128
AMD Bartons 2500
512mb 400MHz PC3200 Mushkin Enhanced RAM

Share this post


Link to post
Share on other sites
effect is simple -- my explination will use OpenGL :D

- create offscreen buffer with ~25% screen dimensions
- render to the buffer
- run seperated convolution filter (guassian blur) on offscreen buffer
- combine buffer with finaly rendered scene.

pretty simple, pretty effect, but its still fake HDR :D

Share this post


Link to post
Share on other sites
Works fine here (7-8 fps with glow effect).

HW : Athlon 1GHz, GeForce FX 5200
SW : Linux/wine.

Share this post


Link to post
Share on other sites
very very pretty app

im runnin an amd 3200+ 32bit
9600xt
1gb pc3200

no bloom ~145fps
bloom on ~45fps

Share this post


Link to post
Share on other sites
Quote:
Original post by vincoof
vsync off, no bloom : min=93 max=129 fps
vsync off, bloom on : min=11 max=11.25 fps

Hardware : P4 2.40 GHz, RAM 512 MB, GeForce FX 5200 Ultra 128 MB AGP 4x
Software : your app in fullscreen, using NVIDIA 61.77 driver on top of WinXP Home SP1.

btw, I think there's a bug in your vsync init. When I start the program, the framerate is locked to 60Hz (+/- 1%) and when I hit F3 it's still locked to 60Hz, and when I hit F3 again the framerate is unlocked (unleashed !). Then whenever I hit F3 it toggles vsync correctly.


Woah 11.25fps! Needs a little speeding up i think!

Quote:
Orig post by skow
Got a link to an explination of how that effect is done?

Yup :) ... I've never actually written any CG stuff with OpenGL before, this link (along with the CG tut on NeHe's site) got me up to speed fast!
Link
The link above is actually a link on how to modify the halflife engine to render glow, but it's V.easy to figure it out, it was almost a cut and paste job! I just hope I can figure out the shader .cg files.

Vincoof, thanks for the vsync bug report, it's just a simple bool being set to wrong value :)

Thanks for testing, I'm so pleased my new game framework code doesn't blow up your PC and actually runs!

Share this post


Link to post
Share on other sites
Quote:
Woah 11.25fps! Needs a little speeding up i think!

It's a FX 5200 = slowest shader unit on earth.

Share this post


Link to post
Share on other sites
Really nice :)

Without ~165 FPS.
With glow ~32 FPS.

Sitting on a P4 1,4Ghz. Geforce 3 64MB. 768MB RAM

Share this post


Link to post
Share on other sites
Quote:
Original post by noVum
Quote:
Woah 11.25fps! Needs a little speeding up i think!

It's a FX 5200 = slowest shader unit on earth.

[lol] I'm pretty sure we can always find a slower unit.
Anyway it still can be optimized IMHO. Even games like Doom 3 run faster than that in this system.

Share this post


Link to post
Share on other sites
fps varies from 341 to 512 with effect off
A solid 146 with it on

3Ghz P4, 256 Meg 6800GT

Share this post


Link to post
Share on other sites
340 with glow off and 100 with it on.
I got a P4 3.0GHz/1GB ram/GF6800ULTRA

What resolution are you running it on?

Allso when i first run it the glow shows up fine, but not the text.
To see the text i have to press F1 to go to fullscreen mode (from fullscreen mode i might add), but if i do that i loose the glow effect until i restart the program.

Is there any other buttons should i be pushing instead.

Share this post


Link to post
Share on other sites
Quote:
Original post by lc_overlord
340 with glow off and 100 with it on.
I got a P4 3.0GHz/1GB ram/GF6800ULTRA

What resolution are you running it on?

Hmm.. 1024x768x32 if I remember.

Quote:
Allso when i first run it the glow shows up fine, but not the text.
To see the text i have to press F1 to go to fullscreen mode (from fullscreen mode i might add), but if i do that i loose the glow effect until i restart the program.

The addition of the cg stuff is really rough, the two textures which are used are not re-created when a screenmode change takes place, that's why the blurring doesn't work after changing to/from windowed mode. I suppose I should've removed screenchanging for this quick test eh?

Quote:
Is there any other buttons should i be pushing instead.

Keys = F1 (to fullscreen) (Ignore this!)
f2 (to windowed) (Ignore this!)
F3 VSync toggle
Escape = quit

Quote:
Alanius - Where's the source?

My source is messy as hell and isn't greatly commented, there's virtually no error checking, values are re-calculated unnecessarily, I'm not proud of this code, I'm actually quite ashamed to show it to someone, but bah, I can't be arsed to sort it out right now as I've been drinking alchohol :) ... the link given above explains perfectly how to implement the effect, yet here is the source file containing the code for the effect, look at the class CGlow. (It's virtually a cut and paste from the aforementioned link tutorial anyway =) www.binaryStudio.co.uk/externallyLinked/CGlow.cpp

[Edited by - TerraX on November 12, 2004 4:33:45 PM]

Share this post


Link to post
Share on other sites
hmm. interesting.

I'm not a great fan of glow effects, and the perfromance hit in this case is pretty staggering... :/

I'm wondering, how you are doing this?

I have done it in the past, and taken the following approach:

render scene to a texture.. (or if D3D use stretchRect)
using two blur textures, 256x256 or 512x512 (you don't need any bigger),
first draw scene to first blur texture, blurring horizontally (single pass, say 8 pixel wide blur, using fudged texture coords and you get even more blur thanks to bilinear filtering). then draw from this texture to the second blur texture, blurring vertically. In a single pass again. I even rotated the first texture 90 degrees to (in theory anyway) help out texture caching...

then draw the second blur texture back onto the screen combined with the original scene texture.

I'm guessing, looking at your shaders, that you are using two full size blur textures (1024x768) and repeatdly blurring them? (I would guess blurring 6 times?) and then running a final shader to pow(3) the result, then draw back to the screen combined with the original scene.. The blur shader seemed to only take 4 samples, and take them in a square, should be possible to do 16-32 samples...

Looks quite good though. it's a pretty accurate blur.

Also consider using auto-mipmap generation to help blurring even more.

but as I say, I'm not a fan of non-hdr bloom... it can easily end up looking like a full screen blur not bloom (eg star wars battlefront)...

anywho blah. [smile]

Share this post


Link to post
Share on other sites
There is no difference between gloom and no-gloom mode here.

ForceWare 70.41 / GeForce 6800

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
256fps off. 65 on

On my Dell Inspiron 9100 Laptop (with ATI Mobility 9800 graphics)

Share this post


Link to post
Share on other sites
'lo,

I got this error message : Fulscreen Display Mode of 1024x768x32 is not supported.

1024x768x32 is my current resolution. Other OGL application work fine. (even mine ;p)
graphic card : Geforce3ti200

Share this post


Link to post
Share on other sites
Quote:
Original post by Corrail
There is no difference between gloom and no-gloom mode here.

ForceWare 70.41 / GeForce 6800

Disable V-Sync !

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Not working on my GeForce 2MX 32mb

Athlon XP 2500+
XP Pro SP2
512mb DDR RAM

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
256 without glow / 113 with glow.

Athlon XP 3200+ / 1.5G RAM / GeForce 6800 Ultra

i find it weird that it's only 256fps without glow when the other person with a 6800U got 340... (text shows up okay without the glow. when using the glow, it's not readable at all)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement