Jump to content
  • Advertisement
Sign in to follow this  
3dmodelerguy

OpenGL linking problems, help please

This topic is 4993 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

i have the source coe from setting up Open GL with WIndows from nehe tutorail 1 and yess i added OpenGL32.lib GLu32.lib and GLaux.lib but i am getting these errors: Deleting intermediate files and output files for project 'OpenGL_Game_Engine - Win32 Debug'. --------------------Configuration: OpenGL_Game_Engine - Win32 Debug-------------------- Compiling... Main.cpp Linking... LIBCD.lib(crt0.obj) : error LNK2001: unresolved external symbol _main Debug/OpenGL_Game_Engine.exe : fatal error LNK1120: 1 unresolved externals Error executing link.exe. OpenGL_Game_Engine.exe - 2 error(s), 0 warning(s)

Share this post


Link to post
Share on other sites
Advertisement
It can't find the Main function.

This probably means you have a WinMain not a Main (eg the nehe code is for a win32 app, not a console app). Simple create a windowed application project instead of a console one.

BTW this question has been asked and answered hundreds of times on gamedev - my friendly advice is to use the handy search function before asking questions.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!