Sign in to follow this  

How to use rgba or RGB16 images with ARB_shadow

This topic is 4776 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I think my limiting factor in my shadowmap is my 8bit shadowmap. I am using the arb_shadow extensions and was wondering how do I setup it to use a 16bit image instead? Shouldn't this get rid of my jaggie staircase looking shadowmap? Thanks

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Quote:

I think my limiting factor in my shadowmap is my 8bit shadowmap. I am using the arb_shadow extensions

That's not possible. ARB_shadow doesn't even support 8bit shadow maps. The minimum is 16 bit (DEPTH_COMPONENT16_ARB). To increase precision, select a higher bitdepth map (DEPTH_COMPONENT24_ARB or DEPTH_COMPONENT32_ARB).

Quote:

Shouldn't this get rid of my jaggie staircase looking shadowmap?

No. It will increase depth precision used to evaluate the depth sample, but it will not smooth the map.

Either increase the shadowmap resolution, or enable some form of smoothing or PCF to antialias the shadows. On nvidia, simply enable bilinear filtering. On ATI, you must write a special pixel shader to get the smoothing.

Share this post


Link to post
Share on other sites

This topic is 4776 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this